USBCNC "R_Comp TD" Problem

Hier kann alles, was mit Postprozessoren zusammenhängt, geschrieben werden.
Benutzeravatar
bs-weiler007
Beiträge: 183
Registriert: 25.06.2008, 16:47
Wohnort: Düren NRW

Beitrag von bs-weiler007 » 12.10.2013, 14:07

Hallo Stefan,

ich habe das von dir geschilderte Problem einfach mal nach gebaut.

Bei mir macht CC das was es soll es schreibt den G-Code sauber in
die NC-Datei. Es werden die Vorschübe so ausgegeben wie ich mir das
vorstelle.

Damit fällt CC für mich als Fehlerquelle erst einmal aus.

Im USBCNC ist es so das eine LOOK AHEAD Bahnvorschau eingebaut
ist. Diese greift in den Standardeinstellungen ab einer Winkelveränderung
von + - 3Grad.

Das soll heißen, dass der Vorschub automatisch runter oder rauf geregelt wird.
das ist wichtig damit man vor Kreisen den Vorschub verringert damit man sauber
die Kontur ausfahren kann.

Das ganze hat etwas mit deinen Rampen zu tun die du in USBCNC unter Einstellungen
einstellen kannst.

Wichtig bei der ganzen Sache ist das du bedenkst, es ist nicht sehr viel platz bei 30mm
bei falsch eingestellten Rampen zu beschleunigen.

Es bleiben dir ja im Grunde nur (30 - 7) /2 also ganze 11.5mm um nun wieder auf den
Ursprungsvorschub zu kommen.

Beispiel:
Ursprung F4500mm/min
Stege F500mm/min

Das ganze kannst du dir nun ausrechnen oder die Tabelle im Handbuch mal ansehen zu
USBCNC. Also hier wird ganz klar du musst beschleunigen, bremsen vor dem Steg, beschleunigen
bis kurz vor der Kurve und da schon wieder abbremsen um diese sauber ausfahren zu können.

Da reicht dann meist das kurze Stück gerade nicht mehr aus um deine Masse in Bewegung zu setzen.

Ich hoffe, das ich dir den Vorgang etwas näher erläutern konnte. Und somit etwas Licht ins dunkle
bringen konnte.

Die Testdaten kannst du dir gerne hier Downloaden

https://www.dropbox.com/s/b34oi8mk1u2r3 ... e_Test.rar


P.S.
Lade dir bitte die aktuelle Version von USBCNC herunter. Und wenn du Interesse hast auch
mal das Handbuch dort stehen sehr viele Sachen die den Umgang und die Arbeitsweise der
Software erklären und beschreiben.


Gruß
Dieter

UniversalPointer
Beiträge: 26
Registriert: 27.06.2013, 16:48

Beitrag von UniversalPointer » 12.10.2013, 16:54

Hallo Dieter,

vielen Dank für die Hilfe. Wird die automatische Anpassung des Vorschubes nicht von USBCNC übernommen? Condacam bzw. der Postprozessor sind daran zunächst doch gar nicht beteiligt?

Problem ist das der G Code nicht so erzeugt wurde/wird wie es sein soll. Ich habe aber Dank deines Beispiels nun zumindest herausgefunden das dies Problem nicht auftritt wenn man bei Außenecken umfahren Kriesbogen wählt. Dann wird der ursprüngliche Vorschub (so wie in Deinem Beispiel) wieder richtig zurückgestellt. Wählt man eine der anderen Einstellung dann tritt das von mir geschilderte Problem auf.

Gruß

Stefan

Benutzeravatar
bs-weiler007
Beiträge: 183
Registriert: 25.06.2008, 16:47
Wohnort: Düren NRW

Beitrag von bs-weiler007 » 12.10.2013, 17:15

UniversalPointer hat geschrieben:Hallo Dieter,

vielen Dank für die Hilfe. Wird die automatische Anpassung des Vorschubes nicht von USBCNC übernommen? Condacam bzw. der Postprozessor sind daran zunächst doch gar nicht beteiligt?

Problem ist das der G Code nicht so erzeugt wurde/wird wie es sein soll. Ich habe aber Dank deines Beispiels nun zumindest herausgefunden das dies Problem nicht auftritt wenn man bei Außenecken umfahren Kriesbogen wählt. Dann wird der ursprüngliche Vorschub (so wie in Deinem Beispiel) wieder richtig zurückgestellt. Wählt man eine der anderen Einstellung dann tritt das von mir geschilderte Problem auf.

Gruß

Stefan


Hallo Stefan,

es ist richtig USBCNC übernimmt natürlich die Vorschubwerte die im NC-File stehen.
Hast du da 4.5Meter programmiert wird immer versucht dies 4.5Meter/min zu halten
es sei denn Kurvenfahrten, Steigungen und der gleichen sollen gefahren werden.
Dann rechnet USBCNC Automatisch den Vorschub aus das deine Maschine die Teile auch sauber
herstellt denn deine Achsen würden bei 4.5Meter/min und einem Radius von 3mm am Ende einer
Geraden mit der Länge von sagen wir mal 300mm da kommst du dann auch gut auf die 4.5meter/min
einfach weiter geradeaus fahren übertrieben und es gäbe gewaltige Schrittverluste.

Deshalb gibt es ja die LOOK AHEAD Vorschau damit du deine Werkstücke so sauber wie möglich
herstellen kannst.

Das dein G-Code nicht stimmt wenn du etwas anderes als Umfahren der Ecken im Kreismodus wählst
kam so nicht bei mir an.

Dazu kann Jens dann denke ich mehr sagen.
Mir ging es mehr um das Verständnis der Arbeitsweisen von CAM und Steuerungssoftware


Gruß
Dieter

UniversalPointer
Beiträge: 26
Registriert: 27.06.2013, 16:48

Beitrag von UniversalPointer » 12.10.2013, 17:20

bs-weiler007 hat geschrieben:...

Das dein G-Code nicht stimmt wenn du etwas anderes als Umfahren der Ecken im Kreismodus wählst
kam so nicht bei mir an.

Dazu kann Jens dann denke ich mehr sagen.
Mir ging es mehr um das Verständnis der Arbeitsweisen von CAM und Steuerungssoftware

...
Das habe ich auch erst nach dem ich mir Dein Beispiel angesehen habe bemerkt.

Gruß

Stefan

Benutzeravatar
3DMSOFT
Site Admin
Beiträge: 1203
Registriert: 07.05.2006, 14:20
Kontaktdaten:

Beitrag von 3DMSOFT » 14.10.2013, 10:12

Hallo Herr Schröder,
so etwas kann z.B. passieren, wenn man im PP den Vorschubblock aus den Kreis-oder Helixsätzen entfernt. In diesem Sinne hätten wir gerne Ihren PP und ein Projekt von Ihnen!

Mit freundlichen Grüßen Jens Tonak

UniversalPointer
Beiträge: 26
Registriert: 27.06.2013, 16:48

Beitrag von UniversalPointer » 14.10.2013, 16:15

Hallo Herr Tonak,

der Postprozessor ist von Dieter:

http://www.condacam.com/PostProzessoren/USBCNC_ATC.txt

und Sie können auch das Projekt von Dieter hierzu verwenden, hier jedoch etwas anderes als Umfahren der Ecken im Kreismodus einstellen:

https://www.dropbox.com/s/b34oi8mk1u2r3 ... e_Test.rar

Gruß

Stefan

Benutzeravatar
3DMSOFT
Site Admin
Beiträge: 1203
Registriert: 07.05.2006, 14:20
Kontaktdaten:

Beitrag von 3DMSOFT » 15.10.2013, 12:03

Hallo Herr Schroeder, danke, wir gehen der Sache nach...

Mit freundlichen Grüßen Jens Tonak

Benutzeravatar
bs-weiler007
Beiträge: 183
Registriert: 25.06.2008, 16:47
Wohnort: Düren NRW

Beitrag von bs-weiler007 » 15.10.2013, 13:59

Hallo Stefan,

Ich habe das ganze nochmal mit allen 4 Varianten des Ecken umfahren
durch getestet und bei mir stimmen die Vorschübe.

Kann es sein, dass du bei dir sonst noch etwas anderes hattest als ich
in meinem Beispiel. ( Maschinenausgabe G41 G42 eingeschaltet vielleicht )


Gruß
Dieter

UniversalPointer
Beiträge: 26
Registriert: 27.06.2013, 16:48

Beitrag von UniversalPointer » 15.10.2013, 18:27

Hallo Dieter,

ich habe in Deinem Beispiel nur das Ecken umfahren geändert und jeweils die PP Ausgabe gestartet:


Bild

Auch am Postprozessor habe ich nichts geändert.

Komisch das es bei Die funktioniert und bei mir nicht...??? Vielleicht findet Herr Tonak die Ursache.

Gruß

Stefan

Benutzeravatar
3DMSOFT
Site Admin
Beiträge: 1203
Registriert: 07.05.2006, 14:20
Kontaktdaten:

Beitrag von 3DMSOFT » 15.10.2013, 18:43

Jep, wir haben schon was gefunden... "Ecken umfahren geändert" Damit ließ sich das reproduzieren.

Mit freundlichen Grüßen Jens Tonak

Benutzeravatar
bs-weiler007
Beiträge: 183
Registriert: 25.06.2008, 16:47
Wohnort: Düren NRW

Beitrag von bs-weiler007 » 15.10.2013, 21:08

Hallo Stefan,

Du hast Recht ich habe das NC-Programm nur im Editor
überflogen und nicht gesehen das der Vorschub dort nicht
erhöht wird. :oops:

Zum Glück hat Jens nochmal drüber gesehen. :!:


Gruß
Dieter

Antworten